Jump to content
Sign in to follow this  
WeAreLegion

Account Linking

Recommended Posts

still not working on EU..

 

i've used the correct information, when i click on link account, the window disappears and nothing happens. i thought i'll try a wrong password or ID, and it said it was incorrect, which means what i've entered are the correct details..

 

did they resolve the issue with EU account linking??

Share this post


Link to post
Share on other sites
5 minutes ago, maXmood said:

still not working on EU..

 

i've used the correct information, when i click on link account, the window disappears and nothing happens. i thought i'll try a wrong password or ID, and it said it was incorrect, which means what i've entered are the correct details..

 

did they resolve the issue with EU account linking??

ok, i think i know where the problem is.. 

my account on the website is set to NA region.. that's why i can't probably link my account.. and i can't find a way to change the region. 

 

any idea what can i do to sort this out?

Share this post


Link to post
Share on other sites
12 hours ago, maXmood said:

ok, i think i know where the problem is.. 

my account on the website is set to NA region.. that's why i can't probably link my account.. and i can't find a way to change the region. 

 

any idea what can i do to sort this out?

Can i create another account on the official page and try to link it? Is it as simple as this?

Share this post


Link to post
Share on other sites
On 3/1/2019 at 11:41 AM, [CM]Shirna said:

We're investigating issues for EU 

 

Any update on this? I still can't link my account.

Share this post


Link to post
Share on other sites
16 minutes ago, maXmood said:

What's your issue exactly??

I get Invalid password/or account doesn't exist error. I've tried loads of times and once it said processing but when I check my account on the website it still says account linking required. I know that my forum account and website account are separate so I know I'm using the right details, I even reset the password and made a new only to still get the error.

Share this post


Link to post
Share on other sites
2 minutes ago, Dejitaru said:

I get Invalid password/or account doesn't exist error. I've tried loads of times and once it said processing but when I check my account on the website it still says account linking required. I know that my forum account and website account are separate so I know I'm using the right details, I even reset the password and made a new only to still get the error.

Maybe it's to do with the EU issue then.. they haven't announced anything about that yet.

Share this post


Link to post
Share on other sites
2 minutes ago, Squibeel said:

Wasn't today the last day of account linking for some reward pet?

Looks like I'll miss that...

The CM's are aware of the Issue so I would like to think they would extend the period of receiving the reward, seeing as it's not our fault.

Share this post


Link to post
Share on other sites
5 hours ago, Squibeel said:

Wasn't today the last day of account linking for some reward pet?

Looks like I'll miss that...

From what I can tell today was the last day to sign up to the website, we have until the 3 April to link our account to be eligible for the pet 

Share this post


Link to post
Share on other sites

Having the same issue. Website says My email is in use, but when I try to log into it says it doesn't exist. Linking from the game says wrong password which I know it is not. Resetting password doesn't work either.

Share this post


Link to post
Share on other sites
2 hours ago, Atreuss said:

Having the same issue. Website says My email is in use, but when I try to log into it says it doesn't exist. Linking from the game says wrong password which I know it is not. Resetting password doesn't work either.

Have the same problem myself. --Momentai :3

Share this post


Link to post
Share on other sites

 It’s probably been mentioned already in this thread but last night @[CM]Shirna mentioned that they are aware of the issue and we have until April to get registered to get the bird. At least that’s what I understood him to be saying, love him to death but sometimes the stream is so busy it’s hard to get the meeting behind some of their statements. 

Share this post


Link to post
Share on other sites

Today it didn't give me an error like usual so it might be working now. Can't verify because it might not have had enough time to show up on the site.

Share this post


Link to post
Share on other sites

Still not working for me. Tried to submit a ticket, but that also requires a linked account to submit one. 😒

Share this post


Link to post
Share on other sites

Figured it out. If you try to register from the game directly on your xbox, it sends you to a console.playblackdesert.com which is totally different from the original bdo account registration. Linking still required after registering, but it DOES work. Click go to website instead of confirm when prompted and you'll be fine.

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/1/2019 at 5:16 AM, WeAreLegion said:

Pro tip: your account for the forum in your account for the official Xbox Black Desert site are different!

In game go to your profile from the menu, It’s Whitehead link account and enter in your information. 👍🏼

Like he stated which I missed after u make a account on the website log on bd and go to profile tap triangle to link ur account remember it's email address for according progress instead of user name and password and link and then ur set to go on website and use ur coupon ty brother. Btw I'm on ps4 so anyone needs help read here on linking up ur account!

Edited by Gremreaper

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/1/2019 at 5:16 AM, WeAreLegion said:

Pro tip: your account for the forum in your account for the official Xbox Black Desert site are different!

In game go to your profile from the menu, It’s Whitehead link account and enter in your information. 👍🏼

 

On 3/4/2019 at 8:23 AM, Atreuss said:

Having the same issue. Website says My email is in use, but when I try to log into it says it doesn't exist. Linking from the game says wrong password which I know it is not. Resetting password doesn't work either.

Start fresh log onto website first then log on to bd and go to ur profile and put in your email and password to link account

Edited by Gremreaper
  • Like 1

Share this post


Link to post
Share on other sites
On 3/23/2019 at 2:59 PM, Roni Southmoor said:

Still not working for me either, keeps saying "Invalid password or account does not exist"

Doesn't work unless u make a account on website from the system !.

Share this post


Link to post
Share on other sites

If anyone still having problems linking account it's probably because u haven't been reading me correctly u log in on your system to black desert make a account write it down then log on black desert press start  press triangle or y and link account to your account u created then link afterwards go back to black desert on your system still and use coupon code submit tickets etc.. anything else lmk ty! Good luck

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...