Jump to content
Hyrule Devil

HUNTING TIME ATTACK QUEST BUGGED

Recommended Posts

Posted (edited)

No matter how many times I’ve tried I cannot advance this questline. First off, when I start the mission, there is no timer. None shows up whatsoever. I found out the proper time after a quick internet search, and even though I would finish the quest AND turn it in within that allotted time (I used a stopwatch) it STILL says the mission timer has expired and cannot be completed. I forfeit, do it again, tried again after every new update, and I still cannot finish this hunting questline because of this bug. NA region on Xbox server. Please help!

Edited by Hyrule Devil
Added region and server

Share this post


Link to post
Share on other sites

I am also stuck on the Hunting mission (Time Attack) Quick and Accurate.  I can't see a timer at all and no matter how fast I kill the wolves and fixes it says I didn't do it in allotted time frame.  I'm on Xbox One S North American Server.

MVIMG_20190902_193232.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...