Jump to content
Silencium

Misty Haze Not Debuffing

Recommended Posts

Misty Haze is failing to debuff mobs in its radius. No -DP Icon tested it through the full duration of the song no debuff appeared. Tried reconnecting to the game didn't help.

Share this post


Link to post
Share on other sites
1 hour ago, Silencium said:

Misty Haze is failing to debuff mobs in its radius. No -DP Icon tested it through the full duration of the song no debuff appeared. Tried reconnecting to the game didn't help.

Do you have any more information on this? Is this happening at a specific time? like siege or node wars? What generation of xbox are you on? Are you doing this skill right after the same skill every time? Any clues that might help us figure out if something might be triggering it? Also, a video would be SUPER helpful. The more details we have, the better. Thank you for letting us know. 

Share this post


Link to post
Share on other sites
11 hours ago, CM_Valtarra said:

Do you have any more information on this? Is this happening at a specific time? like siege or node wars? What generation of xbox are you on? Are you doing this skill right after the same skill every time? Any clues that might help us figure out if something might be triggering it? Also, a video would be SUPER helpful. The more details we have, the better. Thank you for letting us know. 

Any time Misty Haze is cast no debuff icon appears. On Xbox One X. I will have an attatched video link after it uploads. The video will show that Mist Haze is not applying the -10% DP debuff to the mob based off of damage output and no icon appearing. Aside from this it was working fine before the Tuesday update. 

Share this post


Link to post
Share on other sites
13 hours ago, CM_Valtarra said:

Do you have any more information on this? Is this happening at a specific time? like siege or node wars? What generation of xbox are you on? Are you doing this skill right after the same skill every time? Any clues that might help us figure out if something might be triggering it? Also, a video would be SUPER helpful. The more details we have, the better. Thank you for letting us know. 

Attatched is a Video clip of this issue

 

As far as I'm aware of some other people are experiencing this same issue.

Share this post


Link to post
Share on other sites
2 hours ago, Silencium said:

Attatched is a Video clip of this issue

 

As far as I'm aware of some other people are experiencing this same issue.

Thank you for sharing this info! Please submit a ticket and I'll keep an eye out to see if anyone else is experiencing this as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...