Jump to content
Mihari

[EU] Server lags and disconnects

Recommended Posts

@CM_Valtarra

Are there any connection problems with the EU servers today? I'm asking because all EU servers are very laggy today with a high ping and sometimes also disconnecting. Also my friends recognizing this since today morning. Some people in server and world chat are asking about high ping and lags.

Share this post


Link to post
Share on other sites

Still extreme laggs since two days on the EU servers. Game is only playable outside prime time at the momemt.

Share this post


Link to post
Share on other sites

Sorry for the late response! It has been a bit hectic on my end with the holidays. How is it doing today after the patch?

 

CM Valtarra

Share this post


Link to post
Share on other sites

The Lags are MASSIVE. After a minute of running i get a Loadingscreen...every few minutes!! I can´t enter my storage cause of a extremly high delay. After Minutes of waiting maybe it works, but the most time its a trail an error. Changing Servers wont help. Pretty annoying!

  • Sad 1

Share this post


Link to post
Share on other sites

I have been getting a lot of feedback that the last patch helped clear up these issues. Are you seeing improvement?

CM Valtarra

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...